QuantiCode games

Zero Ballistics, Full Metal Soccer

Skip to content

Dedicated server on centos 5 (glibc too old)

Post any problems related to the beta version of Zero Ballistics

Moderators: Michael, Bernhard, Christian

Dedicated server on centos 5 (glibc too old)

Postby msl on 01 Jan 2011, 12:55

Hi,

I'd like to run a ZB server on a centos box, but I can't start it.

I get following error message:
Code: Select all
./server_ded.x86: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./server_ded.x86)


I don't think it's a good idea trying to upgrade glibc because many packages rely on the currently installed version.
msl
 
Posts: 1
Joined: 01 Jan 2011, 12:52
Location: somewhere

Re: Dedicated server on centos 5 (glibc too old)

Postby Christian on 03 Jan 2011, 19:07

Hi sml,

no, upgrading your GLIBC is not a good idea.

Your options are:
- compile the dedicated server yourself (and of course all dependend libs), or hope that somebody else will
- wait for the next release, I will try to compile it with an older linux distro

regards
christian
Christian
Developer
 
Posts: 59
Joined: 29 Mar 2008, 17:21

Re: Dedicated server on centos 5 (glibc too old)

Postby Christian on 03 Jan 2011, 19:42

Perhaps you could give the output of:
strings /usr/lib/libstdc++.so.6|grep -i glib

thx alot
christian
Christian
Developer
 
Posts: 59
Joined: 29 Mar 2008, 17:21


Return to Support

Who is online

Users browsing this forum: No registered users and 1 guest


cron