Page 1 of 1

"could not connect"

PostPosted: 23 Feb 2013, 14:03
by DJFLORIAN42
when I want to connect to a server its brand me "could not connect"
thank you if there's a solution.

sorry if I do not exclaims very well english, I'm french

Re: "could not connect"

PostPosted: 23 Feb 2013, 19:35
by DJFLORIAN42
sorry, the server was deprived

Re: "could not connect"

PostPosted: 27 Feb 2013, 13:16
by Michael
so everything is working now?

cheers,
Michael

Re: "could not connect"

PostPosted: 08 Mar 2013, 14:32
by reetp
Having the same issues here.

Just installed on 12.04 Precise 64 bit. Got the sound running as per another thread and all is well. Just can't connect to a server. At the terminal I get this - same error for any server :

Attempting direct connection to 212.4.121.171:23500...
Direct connect failed. Attempting NAT punchthrough...
ERROR : MasterServerRequest::send ->
Could not connect.


Any way to debug this as I wold like to play online again ?

Re: "could not connect"

PostPosted: 08 Mar 2013, 15:18
by reetp
Also note this when I start the game :

failed to connect to 89.110.149.15:23509...
ERROR : Connect() call failed for quanticode.dyndns.org:23509
failed to connect to UNASSIGNED_SYSTEM_ADDRESS...
Warning : Failed to register a match ID: Failed to contact authentication server.

I also get this :

Warning : element Shape is missing attribute "mass_only".


I can play normally for a little while with bots, and then the game slows to treacle.

Very odd.

Re: "could not connect"

PostPosted: 08 Mar 2013, 15:22
by reetp
Ah, sped it up by reducing the graphics settings and turn off full screen

Re: "could not connect"

PostPosted: 13 Mar 2013, 23:21
by Michael
reetp wrote:Also note this when I start the game :

failed to connect to 89.110.149.15:23509...
ERROR : Connect() call failed for quanticode.dyndns.org:23509
failed to connect to UNASSIGNED_SYSTEM_ADDRESS...
Warning : Failed to register a match ID: Failed to contact authentication server.

Hi

Edit the "config_server.xml" file, the correct address for the master server is:
Code: Select all
    <section name="master_server">
        <variable name="host" value="master.quanticode.com" type="string" />
        <variable name="port" value="23505" type="unsigned" />
        <variable name="heartbeat_interval" value="180" type="unsigned" />
    </section>


Cheers,
Michael