Page 1 of 1

[SOLVED] SourceForge SVN missing models?

PostPosted: 29 Mar 2012, 19:50
by Freder
Hello! I just found out about the game a few days ago through Desura, and decided to test it. As there was no working 64bit version for Linux, I decided to compile my own. I got the sources form SourceForge, followed the build guide, had to upgrade from CEGUI 0.6 to 0.7 and switch libloki for ferrisloki, but the game compiled and seems to work.

The problem is, I can't actually start the simulation. I get the menu, sound etc, but when I start a new game with bots I get some Segmentation Fault, gdb says:
in terrain::TerrainData::getHeightAndNormalBicubic(float, float, float&, Vector&) const ()

When I set the number of bots to 0 on the other hand, I get missing data errors, some of them are:
Cannot load texture data/textures/models/level_light.dds
Cannot load texture data/textures/models/grass06.dds
Cannot load texture data/textures/models/allfirversion1.dds
Cannot load texture data/textures/models/holzende1.dds
Cannot load texture data/textures/models/treelod3.dds
I tried different maps to get each one of them.

Is there an alternate data file set somewhere? I checked the download packages from SF and Desura, they seem to be the same. There doesn't seem to be any model/texture files on SourceForge...

Re: SourceForge SVN missing models?

PostPosted: 31 Mar 2012, 10:20
by Freder
It turned out that there was a problem with the packages I downloaded, and I do have all the resources now. Still hitting a SegFault right after the start of a match though. Will try to get a better backtrace, right now I have this:

Program received signal SIGSEGV, Segmentation fault.
0x00000000008a7bb6 in terrain::TerrainData::getHeightAndNormalBicubic(float, float, float&, Vector&) const ()
(gdb) backtrace
#0 0x00000000008a7bb6 in terrain::TerrainData::getHeightAndNormalBicubic(float, float, float&, Vector&) const ()
#1 0x00000000008a7ef4 in terrain::TerrainData::collideRay(physics::CollisionInfo&, Vector const&, Vector const&, float, bool) const ()
#2 0x00000000006a9146 in Tank::doTerrainWheelCollision(Wheel&, Matrix const&, bool) ()
#3 0x00000000006a684b in Tank::frameMoveTires(float) ()
#4 0x00000000006a1184 in Tank::frameMove(float) ()
#5 0x00000000007eccc7 in GameState::frameMove(float) ()
#6 0x000000000080444c in PuppetMasterServer::frameMove(float) ()
#7 0x00000000007d00bf in NetworkServer::handlePhysics(float) ()
#8 0x00000000007d15ac in Loki::MemFunHandler<Loki::Functor<void, Loki::Typelist<float, Loki::NullType>, Loki::SingleThreaded>, NetworkServer*, void (NetworkServer::*)(float)>::operator()(float) ()
#9 0x000000000094d367 in Loki::Functor<void, Loki::Typelist<float, Loki::NullType>, Loki::SingleThreaded>::operator()(float) const ()
#10 0x000000000094b66d in Scheduler::frameMove(float) ()
#11 0x00000000007d26f5 in SdlApp::run(MetaTask*) ()
#12 0x00000000006804cb in main ()

EDIT: Hurray I fixed it! :D The soulution was here: viewtopic.php?f=4&t=1011

Re: [SOLVED] SourceForge SVN missing models?

PostPosted: 03 Apr 2012, 21:30
by Michael
Hi Freder

Great you managed to compile ZeroBallistics on 64-bit linux!!
Would you like to write some sort of 64bit build guide we could post on sourceforge wiki?

kind regards,
Michael

Re: [SOLVED] SourceForge SVN missing models?

PostPosted: 29 Oct 2018, 20:35
by Kobyimbery
I got news that was all about the missing models it was good to have this on that case that I really have to solve. I was little bit confuse in this report so I got the main report from british essay writer they had all discussion about this case and also have the solution on it.